You are using an unsupported browser. Please update your browser to the latest version on or before July 31, 2020.
close
announcement close button
Home > LoanBeam FAQs > LoanBeam System Requirements
LoanBeam System Requirements
print icon

To use LoanBeam, your computer needs:

Web Browser

You will need one of the following web browsers to use the LoanBeam web Dashboard

  • Microsoft Internet Explorer 9 or newer
  • Google Chrome 23 or newer
  • Mozilla Firefox 17 or newer
  • Microsoft Edge

Operating System

Web Dashboard

Any operating system capable of accessing the internet and on which you are able to install a supported web browser.

 

Note:

For the best experience, use the latest version of your operating system.

Processor

1 gigahertz (GHz) or faster x86-bit or x64-bit processor with an SSE2 instruction set

RAM

2 GB RAM

Screen Resolution

1280 x 800  minimum

Internet Connection

High-speed Internet access is highly recommended

Other

Microsoft Excel 2010 or newer

Microsoft .NET 4.0 or newer

 
Feedback
0 out of 1 found this helpful

scroll to top icon